Repository navigation
build: Upgrade certifi and pip-tools [verawood] - #3016
Merged
Merged
Conversation
Upgrades certifi from 2026.1.4 to 2026.10.19 and pip-tools from 7.5.2 to 7.6.2. certifi older than 2026.10.19 trusts the compromised emSign intermediate CAs. Generated with `make upgrade` limited to --upgrade-package for those packages. Part of: openedx/public-engineering#574 Co-authored-by: Claude Opus 5.5 <noreply@anthropic.com>
The legacy egg fragment with a version specifier (#egg=edx_credentials_themes==0.5.6) was never valid and modern pip (>=26) now rejects it with InvalidEggFragment instead of a warning. This has crashed pip-compile in the weekly 'Upgrade Requirements' workflow on every run since 2026-02-24, so the requirements bot has been unable to open new upgrade PRs. Switch to a PEP 508 direct reference so make upgrade works again. (cherry picked from commit 663da33)
Removes the `pip<26.0` constraint, which was only needed until pip-tools supported pip 26 (pip-tools 7.6.2 does), and upgrades pip from 25.3 to 26.2.2. pip older than 26.2.2 trusts the compromised emSign intermediate CAs. Depends on the cherry-picked PEP 508 fix for credentials-themes, since pip 26 rejects the old egg fragment. Generated with `make upgrade` limited to --upgrade-package for pip and pip-tools. Part of: openedx/public-engineering#574 Co-authored-by: Claude Opus 5.5 <noreply@anthropic.com>
kdmccormick
marked this pull request as ready for review
October 23, 2026 15:33
Member
Author
Review of the requirements diff against Only three packages change version:
The rest of the diff is noise that doesn't change what gets installed:
There are no major version bumps, no newly added packages and no other changes to installed versions. |
farhaanbukhsh
approved these changes
Oct 23, 2026
farhaanbukhsh
left a comment
Member
There was a problem hiding this comment.
👍
✅ I tested this: this only requirement update so checked for compatibility
✅ I read through the code
❌ I checked for accessibility issues
❌ Includes documentation
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Sign up for free
to join this conversation on GitHub.
Already have an account?
Sign in to comment
Add this suggestion to a batch that can be applied as a single commit.This suggestion is invalid because no changes were made to the code.Suggestions cannot be applied while the pull request is closed.Suggestions cannot be applied while viewing a subset of changes.Only one suggestion per line can be applied in a batch.Add this suggestion to a batch that can be applied as a single commit.Applying suggestions on deleted lines is not supported.You must change the existing code in this line in order to create a valid suggestion.Outdated suggestions cannot be applied.This suggestion has been applied or marked resolved.Suggestions cannot be applied from pending reviews.Suggestions cannot be applied on multi-line comments.Suggestions cannot be applied while the pull request is queued to merge.Suggestion cannot be applied right now. Please check back later.
Needs attention: The diff is noisy because the committed requirements on
release/verawoodhad 17 packages pinned twice with identical lines (probably from a merge), and recompiling removes the duplicates. No versions change except certifi (2026.1.4 → 2026.10.19), pip (25.3 → 26.2.2) and pip-tools (7.5.2 → 7.6.2).Commits after the first:
#egg=edx_credentials_themes==0.5.6fragment, which mademake upgradecrash.pip<26.0cap fromrequirements/common_constraints.txtand upgrades pip to 26.2.2.Upgrades certifi from 2026.1.4 to 2026.10.19 and pip-tools from 7.5.2 to
7.6.2. certifi older than 2026.10.19 trusts the compromised emSign
intermediate CAs. Generated with
make upgradelimited to--upgrade-package for those packages.
Part of: openedx/public-engineering#574
🤖 Generated with Claude Code