Repository navigation
fix!: bump urllib3, pytest, filelock and require Python 3.10+ (dependency vulnerability fixes) - #23
Open
devin-ai-integration[bot] wants to merge 2 commits into
Conversation
Co-Authored-By: Devin AI <158243242+devin-ai-integration[bot]@users.noreply.github.com>
Author
|
I'll fix CI failures and address comments from users with write access. I'll skip comments containing "(aside)".
|
…-pkg/urllib3-a66e4043/2026-10-05 Co-Authored-By: Devin AI <158243242+devin-ai-integration[bot]@users.noreply.github.com>
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Sign up for free
to join this conversation on GitHub.
Already have an account?
Sign in to comment
Add this suggestion to a batch that can be applied as a single commit.This suggestion is invalid because no changes were made to the code.Suggestions cannot be applied while the pull request is closed.Suggestions cannot be applied while viewing a subset of changes.Only one suggestion per line can be applied in a batch.Add this suggestion to a batch that can be applied as a single commit.Applying suggestions on deleted lines is not supported.You must change the existing code in this line in order to create a valid suggestion.Outdated suggestions cannot be applied.This suggestion has been applied or marked resolved.Suggestions cannot be applied from pending reviews.Suggestions cannot be applied on multi-line comments.Suggestions cannot be applied while the pull request is queued to merge.Suggestion cannot be applied right now. Please check back later.
Dependency vulnerability fixes (automated)
Generated by the Devin Dependency Security Vuln Fix automation run on 2026-10-26 (PR originally opened 2026-10-05).
Change type: Major version bump — includes source/config changes to adapt to a breaking change.
Warning
We're not just looking for a review like a normal PR. Security can offer this fix as a recommendation, but doesn't have the tooling or domain knowledge to safely verify changes like this end-to-end for each repo. Please review, test, and own deployment before merging. For more information: https://launchdarkly.atlassian.net/wiki/spaces/SEC/pages/5360943572/Dependency+Vulnerability+Remediation+with+Devin.
Findings addressed
Breaking change for consumers (hence
fix!:): every patched release above (urllib3 2.7.0, pytest 9.0.3, filelock 3.20.3) declaresRequires-Python >=3.10, so the package's supported-Python floor is raised 3.9 → 3.10 (Python 3.9 is upstream EOL):pyproject.tomlrequires-pythonandsetup.pyPYTHON_REQUIRES:>=3.9→>=3.10.github/workflows/python.ymlmatrix: dropped3.9README.md: "Python 3.9+" → "Python 3.10+"requirements.txt/test-requirements.txt/pyproject.tomldev group mirror the new floors (filelock >= 3.20.3added explicitly).2026-10-26: merged
main(generated release 25.0.0). The only conflict wassetup.py; resolved toVERSION = "25.0.0"(frommain) +PYTHON_REQUIRES = ">= 3.10"(this PR). The PR diff vsmainis still 6 files / +11 −9. The 25.0.0 regeneration reverted nothing else, but confirms the generator note: these files come from openapi-generator inld-openapi; unless the generator config there is updated (Python floor + dependency floors), future releases will keep conflicting with / reverting this change.Deferred / excluded findings
urllib32.7.0 → 2.8.0 (High ×2 / Medium, GHSA-vxq7-64xx-v4gw / CVE-2026-97689, GHSA-8988-9cw3-xx77 / CVE-2026-97687, GHSA-gh4c-6fx4-qh6g / CVE-2026-97688, 3d). The floor is not raised to 2.8.0 yet; a fresh install already resolves urllib3 2.8.0..travis.yml/.gitlab-ci.ymlstill list Python 3.9; they are generator boilerplate not used by this repo's CI (GitHub Actions) and are left untouched.Verification
pip install -r requirements.txt -r test-requirements.txt && pip install -e .+pip checkon Python 3.10.20 (resolved urllib3 2.8.0, pytest 9.1.1, filelock 4.1.0)pip install -e .builds the package)pytest— 1122 passed on 3.10 (after merging 25.0.0)flake8 launchdarkly_api --select=E9,F63,F7,F82— 0 issues (CI does not run a linter)Note
Overview
Addresses dependency security advisories by tightening version floors and dropping Python 3.9 support in favor of Python 3.10+ (
requires-python/PYTHON_REQUIRES, README, and GitHub Actions matrix).Runtime
urllib3minimum moves from>=2.1.0to>=2.7.0inpyproject.toml,requirements.txt, andsetup.py. Dev tooling bumpspytestto>=9.0.3and adds an explicitfilelock >=3.20.3floor inpyproject.tomlandtest-requirements.txt. Nolaunchdarkly_apisource changes.Reviewed by Cursor Bugbot for commit 076c537. Bugbot is set up for automated code reviews on this repo. Configure here.
Link to Devin session: https://app.devin.ai/sessions/8fbccb467dd4402f85e12e5f1613065c
Open in Devin Desktop: https://app.devin.ai/desktop/session/8fbccb467dd4402f85e12e5f1613065c?variant=devin