From 3fe1a5f4b02a97b709aa187412245c617aab212b Mon Sep 17 00:00:00 2001 From: Karl Bullock Date: Sat, 3 Oct 2026 14:22:40 +0000 Subject: [PATCH] Update the docs for the stable Flarum 2.0 release Removes the release-candidate warnings from the install and upgrade guides, drops --stability=beta from the install command and the minimum-stability: beta upgrade step, and sets the extension upgrade guide's flarum/core requirement to ^2.0. Refs #596. --- docs/extend/update-2_0.md | 2 +- docs/install.md | 8 +------- docs/update.md | 21 ++++----------------- 3 files changed, 6 insertions(+), 25 deletions(-) diff --git a/docs/extend/update-2_0.md b/docs/extend/update-2_0.md index 55e506540..37f74c309 100644 --- a/docs/extend/update-2_0.md +++ b/docs/extend/update-2_0.md @@ -211,7 +211,7 @@ There have been many changes to the core frontend codebase, including renamed or ##### Breaking In `composer.json`: -* Set `flarum/core` package requirement to `^2.0.0-beta`. +* Set `flarum/core` package requirement to `^2.0`. * Set other `flarum/*` packages to `*`. * If you have a `php` requirement, make sure it is not below `^8.3`. * If you have `blomstra/gdpr` as a requirement, change it to `"flarum/gdpr": "*"`. diff --git a/docs/install.md b/docs/install.md index 7669642fd..6e52c498b 100644 --- a/docs/install.md +++ b/docs/install.md @@ -6,12 +6,6 @@ Feel free to give Flarum a spin on one of our [demonstration forums](https://dis ::: -:::warning - -Flarum 2.0 is in its release-candidate phase. The API is stable and many forums already run it in production — but it isn't the final stable release yet, so back up your data and test before relying on it. - -::: - ## Server Requirements Before you install Flarum, it's important to check that your server meets the requirements. To run Flarum, you will need: @@ -65,7 +59,7 @@ Only the latest Flarum 2.x version is detailed here, for previous versions [brow Flarum uses [Composer](https://getcomposer.org) to manage its dependencies and extensions. If you're not familiar with it, read [our guide](composer.md) for information on what it is and how to set it up. Afterwards, run this command in an empty location that you want Flarum to be installed in: ```bash -composer create-project flarum/flarum:^2.0.0 --stability=beta . +composer create-project flarum/flarum:^2.0.0 . ``` While this command is running, you can configure your web server. You will need to make sure your webroot is set to `/path/to/your/forum/public`, and set up [URL Rewriting](#url-rewriting) as per the instructions below. diff --git a/docs/update.md b/docs/update.md index b46ce0052..d00a87d3c 100644 --- a/docs/update.md +++ b/docs/update.md @@ -2,7 +2,7 @@ :::warning -Flarum 2.0 is in its release-candidate phase. The API is stable and many forums already run it in production. It isn't the final stable release yet, so back up your database and test on a staging copy before upgrading a live forum. +Back up your database and files, and test the upgrade on a staging copy before upgrading a live forum. ::: @@ -56,20 +56,7 @@ Set the version string of all extensions (including bundled ones like `flarum/ta "flarum/mentions": "*", ``` -**5. Set `minimum-stability` to `beta`.** -Until Flarum 2.0 reaches its final stable release, your `composer.json` must allow pre-stable versions: - -```json -"minimum-stability": "beta" -``` - -:::info - -Once Flarum 2.0 stable is released, you should change this back to `stable`. Leaving it as `beta` after that point can cause Composer to pull in unstable versions of packages unexpectedly. - -::: - -**6. Update your `config.php` if using MariaDB.** +**5. Update your `config.php` if using MariaDB.** Flarum 2.0 distinguishes between MySQL and MariaDB. If you're using MariaDB, update the `driver` value in `config.php`: ```php @@ -86,10 +73,10 @@ Flarum 2.0 distinguishes between MySQL and MariaDB. If you're using MariaDB, upd 'port' => 3306, ``` -**7. Check any local extenders.** +**6. Check any local extenders.** If your install uses [local extenders](extenders.md), review them for compatibility with Flarum 2.0's API changes before upgrading. -**8. Disable third-party extensions.** +**7. Disable third-party extensions.** We recommend disabling third-party extensions in the admin dashboard before running the upgrade. This isn't strictly required, but makes debugging easier if something goes wrong. ## Running the Upgrade